Degraded Performance - Tracking Page
Resolved
Aug 8, 2026 at 9:03am UTC
Issue Resolved - Tracking Page
Issue Resolved: 6:05 PM IST
We are pleased to announce that the degraded performance issue with our Stellar OMS tracking page has been resolved. The issue was caused by a caching problem due to the Service Worker (SW) cache-first strategy.
Root Cause:
The root cause of the issue was identified as the Service Worker intercepting all same-origin GET requests with a cache-first strategy. Specifically:
The SW was intercepting all same-origin GET requests with cache-first.
Since /track/TOKEN is same-origin, the first visit got cached.
Every subsequent visit, including incognito after the SW installed, returned the stale cached response.
Resolution:
Our team has updated the Service Worker configuration to bypass caching for tracking page requests. This change has resolved the issue, and the tracking page is now functioning as expected.
Verification:
We have verified that:
The tracking page is loading accurately and in real-time.
Browser refresh and incognito mode are working as expected.
Next Steps:
We will continue to monitor the tracking page to ensure that the issue does not recur. If you have any questions or concerns, please don't hesitate to reach out to our support team.
Thank You:
We apologize again for the inconvenience caused and appreciate your patience during this time. Thank you for your understanding.
Affected services
Created
Aug 8, 2026 at 4:34am UTC
Issue Identified: 10:05 PM IST
We are currently experiencing degraded performance with our [App Name] tracking page due to caching issues following the recent backend migration to Cloudflare Workers architecture.
Description:
Users may encounter inaccurate or delayed data while accessing the tracking page. Our team is actively investigating and working to resolve the issue as quickly as possible.
Current Status:
Tracking Page: Degraded performance
Root Cause: Caching issues
Next Steps:
We are working diligently to resolve the caching issues and restore optimal functionality to the tracking page. Updates will follow as necessary.
Workaround:
None available at this time.
Support:
If you have any questions or concerns, please don't hesitate to reach out to our support team. We apologize for any inconvenience this may cause and appreciate your understanding during this time.
Affected services